OpenSource Domain Name Registry Platform1.0.15



Publisher Description

EPP Server, robust EPP-based Domain Name Registry System for New gTLD (.yourbrand) or for second level domains *.yourdomain.com.
EPP Server supports the following RFCs:
- RFC 5730 - (EPP)
- RFC 5731 - (EPP) Domain Name Mapping
- RFC 5732 - (EPP) Host Mapping
- RFC 5733 - (EPP) Contact Mapping
- RFC 5734 - (EPP) Transport over TCP

The interface supports the following object types and transactions:
- Domain commands: check, info, create, update, renew, delete, transfer
- Host commands: check, info, create, update, delete
- Contact commands: check, info, create, update, delete
- Session commands: login, logout, hello, poll

Uses the 'prepaid' billing model.
The EPP Server, gives Registrars the ability to add, modify and delete information associated with domain names, name servers, contacts information on a real-time basis.
It is important to note that each Registrar may only effect information about domain names for which it is responsible.

mod_epp 1.10 for Apache 2.

Features
  • follows the 'Thick Registry' model; all registration information, including contact information, is held in the registry
  • all domain transactions are performed by Registrars in the name of the domain holder (Registrants).
  • uses the 'prepaid' billing model
  • pure Perl
  • support multiple extensions, .yourbrand, .yourbrand.com, ,


About OpenSource Domain Name Registry Platform

OpenSource Domain Name Registry Platform is a free software published in the Network Monitoring list of programs, part of Network & Internet.

This Network Monitoring program is available in English. It was last updated on 29 September, 2026. OpenSource Domain Name Registry Platform is compatible with the following operating systems: Linux, Mac, Windows.

The company that develops OpenSource Domain Name Registry Platform is epp-server. The latest version released by its developer is 1.0.15. This version was rated by 6 users of our site and has an average rating of 2.2.

The download we have available for OpenSource Domain Name Registry Platform has a file size of 225.5 KB. Just click the green Download button above to start the downloading process. The program is listed on our website since 2017-09-27 and was downloaded 131 times. We have already checked if the download link is safe, however for your own protection we recommend that you scan the downloaded software with your antivirus. Your antivirus may detect the OpenSource Domain Name Registry Platform as malware if the download link is broken.

How to install OpenSource Domain Name Registry Platform on your Windows device:
  • Click on the Download button on our website. This will start the download from the website of the developer.
  • Once the OpenSource Domain Name Registry Platform is downloaded click on it to start the setup process (assuming you are on a desktop computer).
  • When the installation is finished you should be able to see and run the program.

Program Details


General

Publisher
Released Date
2017-09-27
Languages
English

Category

Category
Subcategory

System requirements

Operating systems
mac,windows,linux

Download information

File size
225.5 KB
Total downloads
131

Pricing

License model
Free
Price

Version History


Here you can find the changelog of OpenSource Domain Name Registry Platform since it was posted on our website on 2015-04-25. The latest version is 1.0.15 and it was updated on Soft112 on 29 September, 2026. See below the changes in each version:

version 1.0.15

posted on 2017-09-27

version files

posted on 2011-01-22

Several fixes and updates






Click stars to rate this APP!

Users Rating:
  2.2/5     6
Downloads: 131
Updated At: 2026-09-29
Publisher: epp-server
Operating System: Windows, Mac, Linux
License Type: Free